No-ip

Estado
Cerrado para nuevas respuestas.

GilgalaD

Newbie Lvl 6
Bueno busque un poco por el buscador del foro pero encontre poca informacion al respecto.. queria saber si alguien me puede informar si se puede o no usar no-ip con la vercion 0.11.5. encontre un post que ponene un codigo para q se pueda pero capas ahi alguna otra forma.. gracias

no se si este tema va aca si no es asi me disculpo
 
A

Anonymous

Invitado
Claro que si, el No-IP lo podes usar no solo con cualquier AO, sino que con cualquier aplicación que utilice o requiera el uso de IPs. El No-IP (DNS) lo que hace es ponerle un "nombre" a tu IP, para que en lugar de acceder por la IP (por ejemplo, 190.68.45.156), acceden por el DNS (ej, argentum-no-ip.com), y este ademas de ser mas facil de recordar, es mas seguro también en el caso de que tengas IP variable.
 

facundo

Oráculo Lvl 3
NaKruL dijo:
Claro que si, el No-IP lo podes usar no solo con cualquier AO, sino que con cualquier aplicación que utilice o requiera el uso de IPs. El No-IP (DNS) lo que hace es ponerle un "nombre" a tu IP, para que en lugar de acceder por la IP (por ejemplo, 190.68.45.156), acceden por el DNS (ej, argentum-no-ip.com), y este ademas de ser mas facil de recordar, es mas seguro también en el caso de que tengas IP variable.

Creo que en la versión 0.11.5 si pones un no-ip te salta un error..
 
A

Anonymous

Invitado
Hasta lo que yo se la 0.11.5 no tolera noip
Esto no va aca
 

facundo

Oráculo Lvl 3
No use casi nunca la versión 0.11.5 pero buscando encontré este código

Buscas en el FrmOldpersonaje

[vb]<div class="vb" id="{CB}" style="font-family: monospace;"><ol><li style="" class="li1">#If UsarWrench = <span style="color: #cc66cc;">1</span> <span style="color: #b1b100;">Then</span></li><li style="" class="li2">frmMain.<span style="color: #66cc66;">Socket1</span>.<span style="color: #66cc66;">HostAddress</span> = CurServerIp</li><li style="" class="li1">frmMain.<span style="color: #66cc66;">Socket1</span>.<span style="color: #66cc66;">RemotePort</span> = CurServerPort</li><li style="" class="li2">frmMain.<span style="color: #66cc66;">Socket1</span>.<span style="color: #66cc66;">Connect</span></li></ol></div>[/vb]

y lo remplazas por

[vb]<div class="vb" id="{CB}" style="font-family: monospace;"><ol><li style="" class="li1">#If UsarWrench = <span style="color: #cc66cc;">1</span> <span style="color: #b1b100;">Then</span></li><li style="" class="li2">frmMain.<span style="color: #66cc66;">Socket1</span>.<span style="color: #66cc66;">HostName</span> = CurServerIp</li><li style="" class="li1">frmMain.<span style="color: #66cc66;">Socket1</span>.<span style="color: #66cc66;">RemotePort</span> = CurServerPort</li><li style="" class="li2">frmMain.<span style="color: #66cc66;">Socket1</span>.<span style="color: #66cc66;">Connect</span></li></ol></div>[/vb]

No se si sirve.. Fijate..
 
A

Anonymous

Invitado
Bueno, perdón a mi me anda con el No-IP la 0.11.5 pero no sabia que otros tenian problemas. Si te surge algun error, probá instalando la última versión del DUC (No-IP) y si persiste, configuralo para que te autodetecten las conexiones a la IP.

Pido disculpas de nuevo, :)
 

NikoTe

Destructor Lvl 6
Tendria que andar perfectamente con el no-ip. ServerIP= TuIp. no el no-ip, puede ser por eso..
 

GilgalaD

Newbie Lvl 6
Gracias por responder.. el codio ese lo vi pero no anda.. no se que sera yo siempre use no-ip ahora me salta un error cuando lo uso.. ya lo voya solucionar pero sialguien sabe mejor :D

salu2
 

Pocho

Oráculo Lvl 3
lo que no tolera el 11.5 es nombres en vez de numeros, no podes poner localhost tampoco, lo que si, podrias usar alguna especie de transformador de nombre a numeros^^, ingeniatelas
 
A

Anonymous

Invitado
GilgalaD dijo:
Ya probe varias cosas yninguna sirve.. aver si a alguien le paso lo mismo y pudo solucionarlo
Bueno mira recien me baje de nuevo los códigos, y lo único que cambie es lo del checkeo del MD5.
Para crear personajes no tube problemas con el No-IP, pero al intentar conectar con el PJ ya creado me salto un error.
Ese error se soluciona con lo que dijo facundo (arriba) y es que la propiedad HostAddress no acepta nombres, pero la propiedad HostName si.
Si seguis teniendo errores fijate la guia para utilizar el No-IP de ^[GS]^:
no-ip/

PD: Tambien fijate si lo escribis bien, a mi server un amigo que me ayudo a ver esto no se podia conectar porque el No-IP lo hice .servegame.com y escribia server en lugar de serve :oops:
 

GilgalaD

Newbie Lvl 6
jaja igual ya lo arregle.. tenia q cambiar la linea esa q me pusistes arriba q eso lo habia cambiado el otro dia pero en elserver ini enves de poner la ip pona el no-ip :oops: ahora anda lo mas bien. gracias :arrow:
 
Estado
Cerrado para nuevas respuestas.
Arriba