Bug de clones

Rexinto

Newbie Lvl 4
Buenas tardes a todos!

Estoy teniendo un problema que me da un dolor de cabeza importante. Estoy con un bug que esta afectando bastante la jugabilidad, que es el bug de clones. Ya no se que mas hacer para que no me pase. Se cambio todo el modulo de areas, y sigue pasando. Se le bloqueo el telep a los gs a los teleports y sigue pasando.. Por favor, si podrian ayudarnos se los agradeceriamos. Si estan dispuestos a ayudar, podemos hablar en privado para remunerar el fix.


Muchas gracias,
saludos.
 

Rexinto

Newbie Lvl 4
Actualmente, tenemos el modulo de areas virgen de la 13.0 pero ya probamos con un aporte cambiando todo el modulo y no va.
 

Rexinto

Newbie Lvl 4
Es que es variado. Por ejemplo la que me paso recien. Yo estaba quieto, un user paso por adelante mio y cuando apenas salio de mi vision de pantalla, logeo otro user que estaba a dos tiles mios y se clonaron los dos, y vuelan por el mapa aprox. Pasa con npc, y users
 

Rexinto

Newbie Lvl 4
En el log de errores me tira esto:

Error en PasarSegundo. Err: Subscript out of range - 9 UserIndex: 5


(este ultimo numero, puede variar)
 

Rexinto

Newbie Lvl 4
No puedo correr en modo debug los codigos en el host, se traban los codigos. No se como explicarte
 

Rexinto

Newbie Lvl 4
Pasa que no lo puedo reproduccion tan facilmente. Podria probarlo en modo debug yo, pero no se si pueda con otros usuarios
 

Mufarety

Destructor Lvl 6
Si no recuerdo mal no solo se soluciona cambiando el sistema de areas, yo recuerdo que cuando intenté colocarle render 1024x768 tuve que toquetear cosas como rango maximo de vision del personaje, rango maximo de lanzar hechizos y un monton de boludeses que no están en el modulo, que cuando las modifiqué como correspondía se MEDIO solucionó (es decír no era tan frecuente) ahora te paso el post que ví que te explica como está pensado el sistema de areas.

Info 1: https://www.gs-zone.org/temas/areas-en-1024x768-render-a-23x17.91637/
Info 2: https://www.gs-zone.org/temas/reparar-bugs-clones-y-areas-necesario.58583/
Info 3: https://www.gs-zone.org/temas/agrandar-el-area-de-vision-para-agrandar-el-render.77031/

Si encuentro más te los pongo.
 

Rexinto

Newbie Lvl 4
Si no podes ejecutar el servidor en modo debug, nunca se va a poder deprurar el juego.
Se correr el servidor en modo debug. Pero no puedo hacer que el resto se conecte, porque en los codigos de la 13.0 esta el bug de que si se conecta alguien mas con codigos, empiezan las interrupciones, asi me dijo un programador de gs que no voy a dar el nombre.

Si no recuerdo mal no solo se soluciona cambiando el sistema de areas, yo recuerdo que cuando intenté colocarle render 1024x768 tuve que toquetear cosas como rango maximo de vision del personaje, rango maximo de lanzar hechizos y un monton de boludeses que no están en el modulo, que cuando las modifiqué como correspondía se MEDIO solucionó (es decír no era tan frecuente) ahora te paso el post que ví que te explica como está pensado el sistema de areas.

Info 1: https://www.gs-zone.org/temas/areas-en-1024x768-render-a-23x17.91637/
Info 2: https://www.gs-zone.org/temas/reparar-bugs-clones-y-areas-necesario.58583/
Info 3: https://www.gs-zone.org/temas/agrandar-el-area-de-vision-para-agrandar-el-render.77031/

Si encuentro más te los pongo.
Estuve leyendo sobre esto anteriormente. Respecto al primer tema, yo no quiero agrandar el render, quiero que quede 800x600. A lo sumo que le quede lo que tiene implementado la opcion de jugar en modo ventana.
El segundo post, de bug de clones, lo probe y no me funciono, se sigue clonando.
el tercer post no lo conocia, no entiendo bien el funcionamiento que tiene.


Muchas gracias por responder.
saludos
 

Mufarety

Destructor Lvl 6
La idea no es implementar lo que dice de una, te lo pasé para que leas y entiendas para que y como funciona el modulo.
 

Rexinto

Newbie Lvl 4
No soy programador. No tnego el conocimiento suficiente como para sentarme, y hacer un codigo para arreglarlo, ojala pudiera. Gracias de todas maneras
 

Dr. Miqueas150

The Prophet
Ex-Staff
Se correr el servidor en modo debug. Pero no puedo hacer que el resto se conecte, porque en los codigos de la 13.0 esta el bug de que si se conecta alguien mas con codigos, empiezan las interrupciones, asi me dijo un programador de gs que no voy a dar el nombre.

Decile a ese Programador que se vaya a la puta que lo pario.
Vos ejecuta el servidor y anda mostrando los errores que te salen, tanto el cartel como la linea(con el sub entero).
 

Shak

Evolution
Miembro del equipo
Developer
Especialista de Argentum
Decile a ese Programador que se vaya a la puta que lo pario.
Vos ejecuta el servidor y anda mostrando los errores que te salen, tanto el cartel como la linea(con el sub entero).

Pues el que le dijo eso fui yo, pero no le dije eso. Lo que le dije es que en 0.13.0 cuando desconectas un personaje, te salta un error de sockets por lo cual si se desconectaban sus usuarios le iba a ser dificil testiar con ese bug saltando constantemente xD

pd: andate vos a la negra que te pario
 

Dr. Miqueas150

The Prophet
Ex-Staff
Pues el que le dijo eso fui yo, pero no le dije eso. Lo que le dije es que en 0.13.0 cuando desconectas un personaje, te salta un error de sockets por lo cual si se desconectaban sus usuarios le iba a ser dificil testiar con ese bug saltando constantemente xD

pd: andate vos a la negra que te pario

Ah entonces CON MAS RAZON ANDATE A LA PUTA QUE TE PARIO LAUTA
Tenes la 13.5 que fixeo esa mierda, no es una imposibilidad para fixear
 
Arriba