AYUDA CON ERROR AL CARGAR LOS MAPAS

Estado
Cerrado para nuevas respuestas.
A

Anonymous

Invitado
1 punto.
Hola... mi problema es que cuando creo un mapa "desde 0" no me anda al cargarlo con el servidor... osea, en map.dat, modifico y agrego el numero, en el cliente lo pongo tambien, pero NO ME ANDA, me dice que hay error en los mapas porque estan modificados o borrados, o algo asi. En cambio si Agarro un mapa de base. por ejemplo el mapa 20 de la 0.11.2 Que es todo arena, lo modifico y lo guardo como otro mapa, al ponerlo me anda todo perfectamente.

2 punto.
Otra cosa. Como hago para poner el trigger 6 desde el world editor. porque siempre lo tengo que hacer manual con un DIOS desde el cliente y la verdad que hacerlo cuadrado por cuadrado cansa...


Les agradeceria si me responden estas preguntas ya que necesito poder solucinarlos XD

PD: La version para la que creo mapas es la 0.11.2
 

DiCHANHO

by cimsp.net
antes de guardar el mapa.. des tilda "usar nuevo formato para guardar mapas" y listo... agregas el mapa al .dat y tamos..

hay un archivo en el worldeditor que se llama trigger.ini ahi agrégalo.. copiando los otros triggers que ya están incorporados por default.
 
A

Anonymous

Invitado
Si, pero en en los triggers me aparece esto

[INIT]
NumTriggers=6

[Trig1]
Name=Nada

[Trig2]
Name=Des layer 4

[Trig3]
Name=Des layer 4 y AntiRespawn Npcs

[Trig4]
Name=Posicion ilegal pa npcs

[Trig5]
Name=Des layer 4 y No Combate

[Trig6]
Name=Anti Piquete


Entonces aparece como que el trigger6 ya estaria usado para Anti Piquete
por eso no se lo que hacer
 

By3K

Developer
creo q se entendio mal...
segun entendí yo, él quiere que el el trigger 6 no lo tenga q andar poniendo con el GM...
así que abris el mapa con el World Editor, seleccionas Triggers, elegis el trigger 6 de la lista de la izquierda, click en agregar trigger, y clikeás donde vos querés que esté dicho trigger 6.

guardas el mapa y listo..

con eso basta.

ahora si vos tenes un trigger nuevo, solo agregalo como dijo Rayden, y seguí los pasos q t di yo...

Saludos!
 

DarkMage

Destructor Lvl 1
Si vos usas el trigger 6, lo pongas con un GM o lo pongas desde el world editor va a ser para anti piquete

Si vos agregaste un nuevo trigger desde el codigo y le pusiste trigger 6 simplemente ponele trigger 7 u 8 y agregalo al world editor
 

Owangel

Delirando
Tenue dijo:
1 punto.
Hola... mi problema es que cuando creo un mapa "desde 0" no me anda al cargarlo con el servidor... osea, en map.dat, modifico y agrego el numero, en el cliente lo pongo tambien, pero NO ME ANDA, me dice que hay error en los mapas porque estan modificados o borrados, o algo asi. En cambio si Agarro un mapa de base. por ejemplo el mapa 20 de la 0.11.2 Que es todo arena, lo modifico y lo guardo como otro mapa, al ponerlo me anda todo perfectamente.

Primero probá, como explicó el amigo RaYdeN, de destildar la opción de guardar nuevo formato, y si eso no funciona, es porque probablemente estés modificando una ciudad (léase Nix, Bander, Ulla, etc.)
Para poder modificar ciudades y que no te tire errror, tenés que borrar todo el contenido de la carpeta WorldBackUp.
 
A

Anonymous

Invitado
Pero entonces no hay manera de agregar los trigger 6 "de ring" a la lista sin tener que modificar los codigos de fuente?

Porque me aburre mucho ponerlos con un GM ¬¬
 

DarkMage

Destructor Lvl 1
El resultado de ponerlos con el WorldEditor va a ser el mismo ke al ponerlos con el GM, no hagas caso a lo demas

Por mas ke en el worldeditor diga AntiPiquete en tu codigo el trigger 6 es "de ring" asike ponelo trankilamente e ignora ke diga AntiPiquete.
 
Estado
Cerrado para nuevas respuestas.
Arriba